Archived

This topic is now archived and is closed to further replies.

Turning Textures OFF

This topic is 5653 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

this is going to sound really dumb, but I have a slight problem with texturing right now. I''m drawing one object using multitexturing. glActiveTextureARB(GL_TEXTURE0_ARB); glBindTexture(GL_TEXTURE_2D, g_Texture[1]); glActiveTextureARB(GL_TEXTURE1_ARB); glBindTexture(GL_TEXTURE_2D, g_Texture[2]); and the next object I just want to turn the first one OFF. can''t find documentation anywhere on a glDisableTextureARB or some such. I tried binding Texture1 to the same thing as 0 and just letting it stay that way, but it blends them and makes it lighter. I also considered setting it to Decal mode so one will just overwrite the other, but that seems very wasteful. Surely there''s a way to turn one oFF? Thanks in advance.

Share this post


Link to post
Share on other sites
I''m rendering a sphere though and not manually typing in the
glMultiTexCoord2fARB coords. once i''ve bound those two textures to draw the previous objects, it always automatically maps them both onto the sphere. I just want gluSphere to only map ONE of the textures onto it. not turn off texturing altogether.

Share this post


Link to post
Share on other sites
quote:
Original post by DarkYoda42
I just want gluSphere to only map ONE of the textures onto it. not turn off texturing altogether.

Like glBindTexture, glEnable/glDisable with a texture parameter will only affect the current texture unit (the one you last selected with glActiveTextureARB).

Share this post


Link to post
Share on other sites