• Advertisement

Archived

This topic is now archived and is closed to further replies.

Flickering mouse cursors...

This topic is 5714 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Really simple question for you .. I''m using windows XP with a Geforce1, now if i enable transparent cursors it flicks like crazy over my d3d window; i presume because my graphics card doesn''t support transparent cursors in hardware. After turning off transparent cursors, everything is fine. My question is (in case you haven''t guessed); how do i turn off this feature programmatically

Share this post


Link to post
Share on other sites
Advertisement
Win32 API:

ShowCursor(TRUE|FALSE);

will hide the cursor over the client area, leaving you the option to draw your own on the DDraw surface, and no flikering cursors

This happened with me when I installed new card drivers, stopped when I removed them.. wierd

Share this post


Link to post
Share on other sites
I had the same kinda problem. Just draw a cursor of your own over the window. Its dead easy, will look cool, and you''ll know that your program won''t cause this error when run on someone elses machine

Share this post


Link to post
Share on other sites

  • Advertisement