• Advertisement

Archived

This topic is now archived and is closed to further replies.

Visual Assist and DirectX

This topic is 5772 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Damnit, this is bugging me. Visual Assist (latest version) won't recognize any DirectX stuff, so it underlines stuff like CreateDirectDrawEx in red and won't show paramaters. I've added the SDK include directory under the Visual Assist directories tab under Visual Assist properties. I've tried putting the directory at the top and bottom of the lists. I've tried reparsing many times and I've done everything I could find on the net about this problem. This is what my directories look like: =First Box= C:\mssdk\include; c:\program files\microsoft visual studio\vc98\include; c:\program files\microsoft visual studio\vc98\mfc\include; c:\program files\microsoft visual studio\vc98\atl\include; =Second Box= empty =Third Box= C:\mssdk\include; c:\program files\microsoft visual studio\vc98\mfc\src; c:\program files\microsoft visual studio\vc98\mfc\include; c:\program files\microsoft visual studio\vc98\atl\include; c:\program files\microsoft visual studio\vc98\crt\src; Does anyone know a way to get Visual Assist to recognize DirectX? EDIT: I'm using MSVC++6. [edited by - Ivko on June 29, 2002 3:58:33 PM]

Share this post


Link to post
Share on other sites
Advertisement
Go into the visual assist options. Choose directories. Add in the library and header paths to your direct X lib/header directories. Then hit reparse. This should solve the problem.

If it doesn''t it could possibly be due to the fact that your using a beta? (As I haven''t seen a new visual assist out for a while now)

Share this post


Link to post
Share on other sites
I''ve done that, and I''m not using a beta. When it reparses, it mentions nothing about the DirectX headers in the status bar, only MFC and all that stuff. It seems to just skip over the DirectX SDK directories.

Share this post


Link to post
Share on other sites
Try manually including the headers in the project. You know - the "Add File to Project" command. That seems to make the IntelliSense pay attention - maybe VisualAssist will pick them up then...



God was my co-pilot but we crashed in the mountains and I had to eat him...
Landsknecht

Share this post


Link to post
Share on other sites
That worked. I added ddraw.h to my project and changed the #includes, tried compiling and got about 100 errors I then removed ddraw.h from my project, changed the #includes back, and it worked. Thanks.

Share this post


Link to post
Share on other sites
Try adding the directories in the second box, and you woun''t need to add the directX header files to your project each time you want to use it.

Share this post


Link to post
Share on other sites

  • Advertisement