• Advertisement

Archived

This topic is now archived and is closed to further replies.

SDL_image problems

This topic is 5779 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m trying to get SDL_image-1.2.2 to work with SDL-1.2.4 and Mingw32/GCC. I can''t do a full object file compile without getting an error saying the WinMain() function is missing; when I stop the compiler at the object file level with the -c switch, it works all right but then gives error messages when I link the files (in library form) to another program, it gives compile-time errors saying that the SDL_SetError() function is missing. Here are the compiling command-lines: .c file to .o file, full compile: gcc IMG.c -o img.o -lsdl (doesn''t work) .c file to .o file, compile break: gcc IMG.c -c -lsdl (works) .o files to .a file: ar rc libimage.a *sdl_image object files* (works) .c file to .exe file: gcc program.c -o program.exe -lsdl -limage (doesn''t work) So, do I need to download a later version of something? Do I need to link different files, or what? Twilight Dragon Win32 API Expert www.freewebz.com/j-world

Share this post


Link to post
Share on other sites
Advertisement
I know my main function in program.c has all the params; that''s definitely not the problem. The IMG.c file has no main function; it''s not supposed to.

Twilight Dragon
Win32 API Expert
www.freewebz.com/j-world

Share this post


Link to post
Share on other sites

  • Advertisement