Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

bazee

Texture filtering / alignment problem

This topic is 5808 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m working on (yet another) terrain engine. To allow for very large landscapes, I decided to split my terrain into "chunks". Each chunk has its own mesh and its own texture. The meshes fit together nicely, and the textures do fit together nicely when viewed in 2D in Paint. But viewed in DirectX, the borders are clearly visible: 

Screenshot 1

With the bilinear interpolation texture filter disabled, the problem is less noticeable, but still there if you look closely:

Screenshot 2

I have tried all the obvious values for texture coordinates, including:

(0,0)-(1,1)

(1 / TEXTURESIZE, 1 / TEXTURESIZE)-( 1 - 1 / TEXTURESIZE, 1 - 1 / TEXTURESIZE)

(0.5 / TEXTURESIZE, 0.5 / TEXTURESIZE)-( 1 - 0.5 / TEXTURESIZE, 1 - 0.5 / TEXTURESIZE)

etc.

But still can''t get rid of those visible seams!

Someone must have come across the problem before (after all my terrain engine is hardly a new idea!). Any ideas?

Share this post


Link to post
Share on other sites
Advertisement
That is what I did initially. Unfortunately, I need very large non-repeating landscapes and therefore very large textures - too big for any graphics card to handle in one texture. So I must use several textures side by side.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!