Archived

This topic is now archived and is closed to further replies.

Evil Bill

PSP7 alpha channels & TGA files

Recommended Posts

Anyone know how to create a TGA file with alpha in PSP7? The hel says it can save 24bit TGAs + 8bits of alpha, but whenever i add an alpha channel to the image and save it as a TGA, the image comes out with the alpha pre-blended. Cheers, Steve Steve
DirectX Programmer
Soon to be the new Bill Gates

Share this post


Link to post
Share on other sites
24+8 = 32. Alpha tga''s should be always 32bit.

what do you mean by pre-blended ? if you see a b/w or red mask of the alpha instead of the image you need to disable the alpha mask channel. it doesn''t needs to be enabled to be saved properly as an alpha channel.

Share this post


Link to post
Share on other sites
What i mean is this. I convert the first image to a mask (Masks -> New -> From Image then Masks -> Save to Alpha Channel), and then load the mask onto the second image (Masks -> Load from alpha channel). The result is the third image. Then i save it as a TGA and reload it and the result is the fourth image.

Cheers for the reply,
Steve

Steve
DirectX Programmer
Soon to be the new Bill Gates

Share this post


Link to post
Share on other sites
i''m a bit confused but i think it''s what i said.
When you leave the alpha channel visible it shows the alpha in red, and saves like that.

Make sure that you have the alpha channel disabled in the channels menu ...it''s in that small window where you see the different layers. (i don''t have PS7 but i guess it''s still in the same place). Leave the RGB channels visible and click on the alpha channel to make it invisible.

Share this post


Link to post
Share on other sites
Hey Steve,
Theres a fix for this which can be found on the adobe support site. Might have to do a little searching though.

-Lou

edit: here are links to the files
PC- http://www.adobe.com/support/downloads/detail.jsp?ftpID=1544
MAC- http://www.adobe.com/support/downloads/detail.jsp?ftpID=1543

[edited by - seven79 on August 13, 2002 12:11:36 PM]

Share this post


Link to post
Share on other sites
oddly enough, psp7 doesnt let you save a tga as 32 bit... just 24 or
lower. to make a 32bit (tga with alpha) one, you just make your
alpha selection, then go to save selection > as alpha channel
then name it "alpha channel" instead of "selection 1" (dont know
if that''s 100% neccesary or not, i just do it anyway). then
save it.. it''ll save as a 32bit tga automatically.

-eldee
;another space monkey;
[ Forced Evolution Studios ]


::evolve::

Share this post


Link to post
Share on other sites
Its red because i chose the background to be red (which was pretty stupid considering you said that the mask shows up red). The mask only shows up if i goto Masks -> View Mask.
I can''t seem to find the channels menu either (i''m useless ).

I''ll have a look for that fix seven79. Is it an actual bug then and not something stupid i''m doing?

I''ve got the font textures from Quake3 as well, they use alpha TGAs.

Cheers, Steve

Steve
DirectX Programmer
Soon to be the new Bill Gates

Share this post


Link to post
Share on other sites
Its not a bug, just the way they decided to display the alpha in PS7. For some reason, Adobe decided to go against the standard and save transparency info instead of the alpha channel. The plugin works fine though, and reverts it back to the way photoshop used to do things.

-Lou

Share this post


Link to post
Share on other sites