Jump to content
  • Advertisement


This topic is now archived and is closed to further replies.


dx8.1 giving me headaches

This topic is 5885 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I made a working application with my DX8.0 SDK no problems, then I decided to install the DX 8.1 debug version to keep me up to date and because I heard alot of good things about the debug version now everytime I try to compile my programs I made with dx8.0 my vc++ 6.0 exits with "there was an error in MS developer studio and needs to be closed" then when I click "debug error" it says : "unhandled exception in msdev.exe (MSPDB60.DLL): 0xc0000005: access violation" then I get the debug mode :
10312EA4   rep movs    dword ptr [edi],dword ptr [esi]
10312EA6   mov         ecx,edx
10312EA8   and         ecx,3
10312EAB   add         ebx,dword ptr [ebp-0Ch]
10312EAE   rep movs    byte ptr [edi],byte ptr [esi]
10312EB0   mov         edi,dword ptr [ebp-8]
10312EB3   xor         edx,edx
10312EB5   cmp         word ptr [ebp-4],dx
10312EB9   mov         dword ptr [ebp-0Ch],edx
10312EBC   jbe         10312F8A
10312EC2   movzx       ecx,dx
10312EC5   mov         edx,dword ptr [edi+ecx*8+4]
10312EC9   lea         ecx,[edi+ecx*8+4]
10312ECD   cmp         edx,0FFh
10312ED0   mov         dword ptr [ebp-10h],ecx
with a yellow arrow pointing at the first line I did a clean install of windows XP btw and don''t tell me that DX8.1 SDK isn''t compatible with XP, because at the download site of DX8.1 SDK it says that XP is supported can some1 pls tell me whats wrong, I didn''t change a thing in my code and just compiling makes vc++ exiting

Share this post

Link to post
Share on other sites
i assume you already tried reinstalling msvc?

apply the latest service pack (5, i believe) to msvc.

do the sdk samples work from the debugger?

Share this post

Link to post
Share on other sites
well I did a complete format of my PC :D

installed vc++ 6.0

then installed DX8.1 SDK

but I haven''t installed the service pack yet
and yes the samples of the SDK self work

I already tried some other things I made with DX8.0 and they work also, could it be that it''s the d3dfont class is giving me troubles, I will try to replace it now and let you know

thanx for the help anyway

Share this post

Link to post
Share on other sites
just a quick thought...

There are some significant differences between Dx8 and Dx8.1... between directdraw and direct3d.

Is it possible that somewhere in your code you are using the old style classes-memory management-function calls???

i'm guessing that something like that could be easily overlooked and may also cause MSVC++ to act funny.

Just a thought though...


[edited by - commando_337 on August 14, 2002 6:56:21 AM]

Share this post

Link to post
Share on other sites
Do the sdk examples COMPILE and RUN Ok? If yes then there is something wrong with your code. If no then back to the drawing board.......



Share this post

Link to post
Share on other sites

  • Advertisement

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!