Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

BlackScar

OpenGL OpenGL Blending and masking...

This topic is 6769 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! The last few days I''ve been learning heavily on OpenGL. But the tutorials on the net that I were reading had to disable the depth-testing whenever I blended or masked something. How can I blend or mask something without disabling the depth-test? Thanks alot! Justin Eslinger

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
I''m working on a 3D game engine. To render water I had to use blending. disabling the Depth test created a lot of problem. I think i can give you details: szafar@ssuet.edu.pk.

Share this post


Link to post
Share on other sites
you don''t have to disable depth test.. it''s just that if you draw the poly''s out of order it''s gonna have odd effects.
ie: picture you want to have a wall and a window in front of it.. you should draw the wall then the blended window after that.. right? otherwise if you draw them out of order.. you have a blended window drawn, then nothing drawn behind it since the depth of the window is in front of the wall.
get it? good.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!