Archived

This topic is now archived and is closed to further replies.

Mounting Questions

This topic is 5602 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ok I have a couple of questions to do with mounting drives under linux(I''m using RH 7.3 btw) 1.Is it possible to mount an NTFS partition. Or is it a closed standard that only MS knows the details of? 2.I have a a small 1 gig partition formatted to fat32 used to swap files between windows and linux due to my current inablility to mount NTFS partitions. The only problem is veryone can read from it but only root can write to it. Any suggestions on how to set it up so everyone can write to it?

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
quote:
Original post by Monder
1.Is it possible to mount an NTFS partition. Or is it a closed standard that only MS knows the details of?



Read-only is well supported, I''m not sure about read-write. Back two years ago, read-write was the best way to corrupt your NTFS partition. It might be different nowadays though.

mounting read-only should be as simple as:

mount -t ntfs /dev/your_ntfs_partition /where/to/mount

read-write, I assume, would be something like:

mount -t ntfs -o rw /dev/your_ntfs_partition /where/to/mount

However, if things haven''t changed, writing to your NTFS share is the best way to crush it.


quote:

2.I have a a small 1 gig partition formatted to fat32 used to swap files between windows and linux due to my current inablility to mount NTFS partitions. The only problem is veryone can read from it but only root can write to it. Any suggestions on how to set it up so everyone can write to it?


Try to force read-write (-o rw): normally ''mount'' mounts read-write by default (on GNU/Linux at least), but it might differ with VFAT. Also check the umask, you might have to specify one yourself (man mount and man umask will help). ''mount'' will use the umask of the current process if none is specified (the default is 022): changing it to 000 would enable *any* user to do whatever is specified by the open mode.

Therefore:

mount -t nfs -o rw umask=000 /dev/your_ntfs_partition /where/to/mount

could do the trick. However, I encourage your to set stricter permissions in order to preserve your share.

Sorry for not helping much, but I don''t have a Windows box nor a VFAT/NTFS partition to try and help.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
The last mount line should be:
mount -t ntfs -o rw umask=000 /dev/your_ntfs_partition /where/to/mount

and not ''nfs'', or you''re going to have trouble mounting that one .

Share this post


Link to post
Share on other sites