Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

lakibuk

MIDI file playing corrupt

This topic is 5817 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I use direct music to play a midi file. On a few soundcards (like my new one) the file isn''t played correct. It sounds like garbage, parts are played too fast and then it stops. It even interrupts the whole game for some moments. What could be the problem? I am using the midi playing functions from the directx7 tutorials.

Share this post


Link to post
Share on other sites
Advertisement
Check your Drivers. Also try changing the output device (or whatever) between the sound card, software synth, etc.

Do not meddle in the affairs of moderators, for they are subtle and quick to anger.


ANDREW RUSSELL STUDIOS
Cool Links :: [ GD | TG | MS | NeHe | PA | SA | M&S | TA ]
Got Clue? :: [ Start Here! | Google | MSDN | GameDev.net Reference | OGL v D3D | File Formats | Go FAQ yourself ]

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!