Archived

This topic is now archived and is closed to further replies.

Antialiasing

This topic is 5595 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello What else I need to do, my antialiasing is not working I know my geForce2 supports 4 multisamples. It works with the SDK samples.
  
D3DPRESENT_PARAMETER d3dPP;
ZeroMemory( &d3dPP, sizeof( d3dPP ) );
d3dPP.Windowed        = FALSE;
d3dPP.SwapEffect      = D3DSWAPEFFECT_DISCARD;
d3dPP.MultiSampleType = D3DMULTISAMPLE_2_SAMPLES;
pD3D->CreateDevice(D3DADAPTER_DEFAULT, D3DDEVTYPE_HAL, hWnd,
                   D3DCREATE_SOFTWARE_VERTEXPROCESSING,
                   &d3dpp, &d3dDevice);

d3dDevice->SetRenderState (D3DRS_MULTISAMPLEANTIALIAS, TRUE);  
Thanks

Share this post


Link to post
Share on other sites
Have you made sure that the video card settings are allowing antialiasing? If you are using windows 98 with detinator drivers, right click on the desktop->Properties->Settings->Advanced->Geforce 2 tab->Additional Settings->3D antialiasing settings. There should be some settings under there that you might need to change so that it will let your program do antialiasing.

Moe''s site

Share this post


Link to post
Share on other sites
Thanks for pointing to this settings, I did not know it exists, it has things I was looking for, however it is not the cause of the problem.
I guess I have to dig into the code further, I am sure I am resetting a flag or missing a piece of code.
Thanks a lot

Share this post


Link to post
Share on other sites