Archived

This topic is now archived and is closed to further replies.

Locales messed up

This topic is 5589 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello all. I seem to have messed up my locale settings somehow. I first noticed when I was receiving messages on LICQ, and the special characters in the swedish language were messed up. People i was sending messages to asked if I was drunk, so I suppose the messages they got looked strange also. I fired up a term, and looked at what environment variables I had. Everything that had to do with languages was set to en_US. I would like to have them in swedish, sv_SE. So, naturally (I thought), I added this to my .bashrc export LANG=sv_SE export LC_CTYPE=sv_SE export LC_MONETARY=sv_SE export LC_COLLATE=sv_SE export LANGUAGE=sv_SE export LC_TIME=sv_SE export LC_NUMERIC=sv_SE Logged out, logged in again, did a env | grep sv_SE to verify they were set correctly. They were. Then, I started X. Fired up a term, did the same thing. Nothing. I checked all env variables, and they were all set back to en_US Where did that happen? What do I need to change? system: linux, XFree86 4.10, KDE 2.2.2

Share this post


Link to post
Share on other sites
Look in the following directories:
$KDEBASE/share/config (Global KDE configuration files)
~/.kde (Hidden per-user configuration files)
$KDEBASE/share (Global KDE shared resources)

Also try Settings->Desktop->Language from the KDE Menu.

[Edit: formatting.]

[edited by - Oluseyi on August 26, 2002 12:20:24 PM]

Share this post


Link to post
Share on other sites
Thank you for your reply, Oluseyi.

I looked in the KDE control panel to see if the language had changed. It hadn't, it was set to sv_SE, as it has been all the time.

I did a grep in the directories you mentioned to see if I could find anything useful. Didn't find anything that semt to be causing this, though.

I also noticed something else, which confuses things even more. If I run the program locale from a terminal window in kde, it shows that all those variables are actually set to sv_SE, except LANG, which is to "en"

Still, when I look at the environment variables in a kde terminal (does the same thing with xterm, so it can't be kde a terminal related problem), they are all set to en_US.

I honestly have no clue to what the problem is here. Anyone else?

(edit: oops, unclosed italics tag)


[edited by - mr BiCEPS on August 28, 2002 9:36:00 AM]

Share this post


Link to post
Share on other sites