Archived

This topic is now archived and is closed to further replies.

strange problem

This topic is 5581 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

am working in my a new 3d engine and i designed my new engine to make the message loop completly in its own thread.. i am experiecing very strange problem when i started to work on rendering bsp level (quake3) the program works in very good .... and while am working on visual c.. i usualy compile and test i sometimes find the performace crawling (6 fps) and i find no reason for this slowdown i restart the pc.. and i find the performance back to normal without modyfying anything in the code.. its the same exe running what might be the reason? Flutey Shady El Mously Egyptian Game Programmer (there is no knowledge that is not power)

Share this post


Link to post
Share on other sites
My best guess here is that you have some massive memory leaks in your program. Quake3 BSP take up a lot of memory. If you don''t delete it at the end of your program, each time you start it (or a new compiled version of it) you''ll loose memory until there is not enough left to execute properly and strange things start to happen. After a reboot all this leaked memory is gone and the program has enough to run again.

Sander Maréchal
[Lone Wolves Production][Articles][GD Emporium][E-mail]

Share this post


Link to post
Share on other sites