Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

ECKILLER

texturing an md2 model

This topic is 6706 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I have an md2 rendered correctly in wireframes. But now i need to texture it. Here''s what i got: Given: verts and st are valid pointers and contain correct data. Also you should know that this code gets called in a loop once for each primitive in the model. This should be hopefully just opengl syntax that i''m doing wrong. Or need to do. glEnableClientState(GL_VERTEX_ARRAY); glEnableClientState(GL_TEXTURE_COORD_ARRAY); glVertexPointer(3, GL_FLOAT, 0, verts); glTexCoordPointer(2, GL_FLOAT, 0, st); if(model->Primitives.PrimitiveType == MD2_TRIANGLESTRIP) { glDrawElements(GL_TRIANGLE_STRIP, model->Primitives[i].NumFaceIndices, GL_UNSIGNED_INT, indices); } if(model->Primitives[i].PrimitiveType == MD2_TRIANGLEFAN) { glDrawElements(GL_TRIANGLE_FAN, model->Primitives[i].NumFaceIndices, GL_UNSIGNED_INT, indices); } Thank you. ECKILLER

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!