Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

juhaszt

Multipass texture blending

This topic is 5881 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When I use multipass texture blending as described in the DirectX SDK documentation it works fine, but only when I use 16bit Z-buffer depth. When I use 32 bit Z-buffer depth, there are always a few pixels where the texture rendered in the first pass appear, without the belended second pass. My card is a Geforce2 MX. Has anybody similar problems? Is it perhaps a general video card problem (with Geforce2 MX)??

Share this post


Link to post
Share on other sites
Advertisement

Are you setting the zbias on your second pass to ensure it renders on top? (I suspect not)

Share this post


Link to post
Share on other sites
You are right, I do not set the Z bias, but the documentation does not mention that as a necessary thing. When I render the same triangles in the second pass the calculated pixels should have the same Z value as the pixels in the first pass, and so the second pass should be blended right with the default D3DRS_ZFUNC state. Am I right?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!