Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Marius

multi textures ???

This topic is 5934 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a simple scene having 2 textures (images+lightmaps). I generate them glGenTextures(1,&iTex); glTexImage2D( GL_TEXTURE_2D,0,3, x,y,0,GL_RGB,GL_UNSIGNED_BYTE,pBuff); gluBuild2DMipmaps(GL_TEXTURE_2D,3,x,y, GL_RGB,GL_UNSIGNED_BYTE,pBuff); glTexParameteri(GL_TEXTURE_2D,GL_TEXTURE_MIN_FILTER, GL_LINEAR); glTexParameteri(GL_TEXTURE_2D,GL_TEXTURE_MAG_FILTER, GL_LINEAR); // I draw them as ususlly they are drawn glActiveTextureARB(GL_TEXTURE0_ARB); glEnable(GL_TEXTURE_2D); glBindTexture(GL_TEXTURE_2D, pTex[0]); glActiveTextureARB(GL_TEXTURE1_ARB); glEnable(GL_TEXTURE_2D); glBindTexture(GL_TEXTURE_2D,pTex[1]); // the the vertexes - If I change in one of ''glTexParameteri'' last flag GL_LINEAR to something ele but still valid for the GL_TEXTURE_***_FILTER, I get the second pass texture missing. Also some of others textures are messed around in the scene. Any suggestions ? Thanks. MCO

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!