Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

pb123

release exe's

This topic is 5761 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have built my release version with no errors but when I try to double click an exe it does nothing. I get an hourglass and then nothing. If I rebuild in debug (just the exe) it works fine. Any suggestions...???

Share this post


Link to post
Share on other sites
Advertisement
That could be due to an uninitialised variable. IIRC, in debug mode, primitives are given a default value, but in release mode, they aren''t.

For example, if you have this...

bool done;
while (!done) {
  ...
}


...then what you need is this:

bool done = false;
while (!done) {
  ...
}


Just a guess

Share this post


Link to post
Share on other sites
The few times I''ve had this problem, it has been because I''ve been overflowing a buffer.

example:

char filename[32];

strcpy(filename, "C:\myprojects\newproject\gfx\image1.bmp");

Like that. Because that string is more then32 chars...

/MindWipe


Share this post


Link to post
Share on other sites
In VC++ 6.0 variables are not given a default value. Or perhaps they are. At least any uninitialised variable shows a value of -81901921 (or so) in Debug mode.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!