Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

ji yan

Weirdest problem I've ever met

This topic is 5852 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi: I was running my code and everything seems alright until the process gets to this line: g_pd3dDevice->Clear( 0, NULL, D3DCLEAR_TARGET|D3DCLEAR_ZBUFFER, D3DCOLOR_XRGB(0,0,255), 1.0f, 0 ); It was not any kind of error that poped up. Instead, VC++6 gave me a hint on a message box : "User Breakpoint called from code at 0x77f7570". The result is the same as as if I have added a breakpoint somewhere where the program stops at, and when I continue executing, everything is normal except every time, the execution pauses at the same line of code and gives out the same message. Has anyone before ever encountered so weird problem like this one? I need help on it pliz.... Thanks for your hlp in advance

Share this post


Link to post
Share on other sites
Advertisement
Is your g_pd3dDevice variable valid?
Theres probably a line
assert(this);
in the D3D source code.

HTH, Steve

Steve
DirectX Programmer
Soon to be the new Bill Gates

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!