Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Lucky_Dave

DirectDraw: vertical lines appearing instead of transprent color

This topic is 5788 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am blitting DD7 surfaces onto my backbuffer. My problem is that my transparent color is not transparent. Instead, it displays vertical lines, one transparent, one with the color that was supposed to be transparent, and so one. What''s happening ? Anyone would help please ?

Share this post


Link to post
Share on other sites
Advertisement
Make sure the size of the destination and source rects are equal. I''ve run into similar problems when they were off by one or something like that.
-Andrew

Share this post


Link to post
Share on other sites
Dest and source rects do not have to be equal. Eit her one can be larger or smaller than the other. Are you converting your transparent color to the current bit depth before you send the value to the surface?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!