Archived

This topic is now archived and is closed to further replies.

X_Breaker

Having problems with tutorial 10, the world tutorial.

Recommended Posts

I can't get anything displayed in the window. I'm pretty sure that the world is being loaded correctly from file, but nothing is showing up on the screen at all. I tried copying the source code into various points in my project, and then tried compiling the source code by itself. Although it compiles, the executable doesn't run at all. The executable that comes with the source does run, though, and I can see what the results are supposed to look like. Here's a link to my cpp file. Maybe somebody can take a look at it and tell me what I'm doing wrong. I've scoured over it all day, and I can't figure out what the problem is. I haven't had any problems displaying things to the screen in any of the tutorials so far, so this has thrown me. http://students.uww.edu/bundajw08/createwindow.cpp [edited by - X_Breaker on October 17, 2002 7:09:34 PM]

Share this post


Link to post
Share on other sites

filein = fopen("World.txt", "rt"); // Open the file.

Are you sure you''ve got the world.txt in the right place in your directory

Debug up to this line and see what value filein is.

Share this post


Link to post
Share on other sites
you have commented out the code to setup and enable light 2, yet you still are allowing disabling/enabling lighting... so my guess is that you can''t see anything because there is no lighting (pressing L will hopfully toggle lighting)

<-- smile :-)

Share this post


Link to post
Share on other sites
check your gluPerspective settings.. the relation to the drawn map has to be right. and the viewing distance could even make some problems ( did not look into your sourcecode but this was an error i had while rendering bsp files )

Share this post


Link to post
Share on other sites