Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

stodge

Problem setting socket to non-blocking in Windows

This topic is 5729 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m trying to use ioctlsocket in Win2k to set my socket to non-blocking using the following code:
  
unsigned long nonblocking = 1;
SOCKET socket;

status = ioctlsocket (socket, FIOASYNC, &nonblocking);
  
I''m getting back an error of "Invalid command or argument for socket options." (EINVAL). Any ideas what might be wrong with my code? I''m doing this ioctlsocket call straight after I''ve created the socket. Thanks

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
the correct parameter is "FIONBIO", e.g.

ioctlsocket (socket, FIONBIO, &nonblocking);

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!