Archived

This topic is now archived and is closed to further replies.

dolphy

How do you stop flickering of mesh.

Recommended Posts

I am using ID3DXMESH to read a .x file and draw it on my view. I move around the object by changing my eye position and my look at point. I don''t change the world matrix. But every time I move around, (i.e. move the eye and look at point) parts of the mesh flickers. First I thought that it was becase of culling but I tried all cull modes but got the same results. Is there any other options that I can set to stop this flickering? Thanks in advance.

Share this post


Link to post
Share on other sites
Your near and far clipping planes have been set too ''far''. By far I mean that either the near clip plane has been set too small, or yout far clipping plane has been set too large.

Basicly the z-buffer has a finite amount of accuracy. If your near clipping plane is too close oryour far clipping plane is too far away, then the accuracy of the z-buffer is reduced. If you render in 32bit mode, then this should reduce the flickering effect, but you would be better off changing your clipping plane values.

Hope this helps

James

Share this post


Link to post
Share on other sites