Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Cherub

urgent font and md3 problem....

This topic is 5751 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I''m having this problem: I load a md3 model in my app, but when I load fonts the model turns the color of my font and the font disappears.... what could be wrong? Thanks

Share this post


Link to post
Share on other sites
Advertisement
You need to pop the push a new matrix onto the stack for use. Otherwise when you change the colour it will affect all the objects drawn.

To push and pop, you do

    
glPushMatrix();
//..draw the object

glPopMatrix();

glPushMatrix();
//..draw font

glPopMatrix();



This should do it.

Hope this helps

Broni


[edited by - Broni on October 20, 2002 3:10:07 PM]

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Are you setting the texture before_each_render?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!