Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

ATronic

NeHe's iPicture code and DevC++

This topic is 5828 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all, I''ve been trying to get NeHe''s ipicture code to work in a devc++ project of mine. I get tons of errors in "olectl.h". Enough so that at the end of the errors DevC++ helpfully commented that "There must be something terribly wrong with your code. Please fix it." Any help would be greatly appreciated. Alex Broadwin A-Tronic Software & Design ----- "if you fail in life, you were destined to fail. If you suceed in life, call me." "The answer is out there." "Please help, I''m using Windows!"

Share this post


Link to post
Share on other sites
Advertisement
Hi again, here''s some more information. It generated a total of 480 errors. The error log can be found at:
http://www.a-tronic.com/log.txt

I can''t seem to find any way to fix this. I also tried having devc++ import NeHe''s own vc++ project that demonstrates the iPicture code, but the results were basically the same: hundreds of errors. Thanks ahead of time to anyone who helps.

Alex Broadwin
A-Tronic Software & Design
-----
"if you fail in life, you were destined to fail. If you suceed in life, call me."
"The answer is out there."
"Please help, I''m using Windows!"

Share this post


Link to post
Share on other sites
I can''t really test anything about this right now (later tonight, as in 4:00 AM MST, I might be able to get access to a Windows box), so my only guess is that you could possibly need updated MinGW32 headers (mingw.sourceforge.net) or that there could be a bug in their headers.

Share this post


Link to post
Share on other sites
I believe I have the latest headers. I could not find the latest ones on the site you gave me, though, so I''m not posative. Has ANYONE managed to get the iPicture code working in DevC++, or even tried for that matter?

Alex Broadwin
A-Tronic Software & Design
-----
"if you fail in life, you were destined to fail. If you suceed in life, call me."
"The answer is out there."
"Please help, I''m using Windows!"

Share this post


Link to post
Share on other sites
If you''re interested, I''ve fixed the headers to remove all the errors, but IID_IPicture isn''t in the libraries, so I''m trying to find a way around it.

Share this post


Link to post
Share on other sites
Ooo, really? Wow, I am most certainly interested. What exactly was the problem? If you could post the headers or email them to me at atronic@gamebox.net it would be much appreciated.

Alex Broadwin
A-Tronic Software & Design
-----
"if you fail in life, you were destined to fail. If you suceed in life, call me."
"The answer is out there."
"Please help, I''m using Windows!"

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!