Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

skow

Normal key detection (VK_A) not working

This topic is 5858 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey Ive been using VK_SPACE or VK any thing and its been working fine, my site that i use for all the assigned VK''s says for normal charicters use VK_A for a. This isnt working. Is the site wrong? do i have to include something? Thanks for the help

Share this post


Link to post
Share on other sites
Advertisement
Looked it up there...they say it works

what am i doing wrong ?

Syntax
public static final int VK_A
Description
VK_A thru VK_Z are the same

Share this post


Link to post
Share on other sites
From memory if you look in the header file which declares VK_SPACE etc. it actually says to use the ascii codes for A through to Z and it does not define VK_A etc.

if MSDN says to use VK_A then it is not consistent with the header (at least when I last looked at it which was about a year ago)

Hope that helps
Toby


Gobsmacked - by Toby Murray

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!