Archived

This topic is now archived and is closed to further replies.

Loading Midi files

This topic is 5504 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

strange problem: how come that you may load (with the "LoadSegment" function of the DirectMusic samples) a particular Midi file (in this the prebabricated Canyon.mid - the sample.sgt as well) whereas another one would not work (passport.mdl - another prefab). - I thought that Midi Data should be loaded anyway, even if referred DSL files do not exist. Am I wrong? My hypotheses is that the object description does not fit. Another peculiarity I do not understand? What does the prefix L mean, like in L"Canyon.mid Help is deeply appreciated.

Share this post


Link to post
Share on other sites
this is seems to be a very special, and known problem (since a net research gave some results).
One of the suggestions there was that the "could not load segment" errormessage was a result of the directory path setting.

Any idea?

[edited by - MB on November 21, 2002 5:03:41 PM]

Share this post


Link to post
Share on other sites
although this is monologuous, resolving the problem might be useful to others.
So - I can confirm it now. When you use the dir_path in the DirectMusic samples the loading of segments may cause an error. If you comment these lines out and use the working directory instead, it runs fine.
Strange,

Share this post


Link to post
Share on other sites