• Advertisement

Archived

This topic is now archived and is closed to further replies.

LNK2001 errors

This topic is 6470 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I am having some trouble compiling the tutorials... I copied the code word for word out of the tutorial page, but after fixing my typographical errors I am have recieved LNK2001 errors, like the one below: lesson1.obj : error LNK2001: unresolved external symbol __imp__glLoadIdentity@0 I have consulted with a friend, and he is also getting the same errors, but from a different project. Could somebody please help us. Thank You, Morgan

Share this post


Link to post
Share on other sites
Advertisement
I''m no C++ freak (yet) so I may be way out now, but I think you''re missing a .lib file or possibly a .h file. Since that''s an OpenGL function missing. Make sure that your OGL libraries are available.

============================
Daniel Netz, Sentinel Design
"I'm not stupid, I'm from Sweden" - Unknown

Share this post


Link to post
Share on other sites
ya, that error message means you''re not linking a neede library file. It looks like it could be OpenGl.lib (or OpenGl32.lib)

Share this post


Link to post
Share on other sites
Yeah, I know. I''ve tried adding it to whatever the hell that dialog is which has the long string of libs in it, but it doesn''t work. I finished the demos a long time ago. I got through atleast ten ports of my Mac demos before the problem started occurring, now my friend is having the problems too. I usually use straight GLUT (for maximum compatibility) do I do a straight Win32 Consolse application for that (I can''t remember which I used to use which worked) or a Win32 app?

Morgan

Share this post


Link to post
Share on other sites
if you are using VC++ you just need to add the lib (opengl32.lib probably) goto
projects -> settings
choose "link"
then in the bottom add(or make sure they are there)
opengl32.lib glu32.lib glaux.lib
and that those libs are in you lib path..
if you D/L the projec files , these are already added(you need to add them each time)
i'm not stupid i'm just swedish?
nice qoute




Edited by - phearbear on 5/3/00 4:25:57 PM

Share this post


Link to post
Share on other sites

  • Advertisement