• Advertisement

Archived

This topic is now archived and is closed to further replies.

XFree86 startup error - no screens found

This topic is 5546 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi there! I have recently installed Debian 3.0 from a Linux Format DVD, and have specified in the installation to install XFree86 and I configured my display (Gateway EV700). When I start up the computer Debian displays the scrolling text. But when I get to the console login the screen flashes to all black two to three times. I then get an error message that says something along the lines of 'I cannot start up XFree86. Would you like to view the log file?'. The XFree86 log contains the following error message:
(EE) Screen(s) found, but none have a usable configuration
 
Fatal server error:
no screens found
     
After this, I have to stay in console mode. I am running Debian 3.0 on an ATi Xpert 128 16MB PCI and a Gateway EV700 monitor. A search showed that a lot of people were having this problem with different graphics cards and different distrobutions, but I could not find an answer. Thanks for your consideration. [edit: here is the Screen, Device, and Monitor portion of xf86config-I hope this will help]
        
Section "Device"
        Identifier     "Generic Video Card"
        Driver         "ati"
        Option         "Use FBDev"        "true"
EndSection
Section "Monitor"
        Identifier     "Generic Monitor"
        HorizSync      30-57
        VertSync       43-72
        Option         "DPMS"
EndSection
Section "Screen"
        Identifier     "Default Screen"
        Device         "Generic Video Card"
        Monitor        "Generic Monitor"
        DefaultDepth   24
        SubSection "Display"
                Depth        1
                Modes        "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth        4
                Modes        "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth        8
                Modes        "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth        16
                Modes        "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth        24
                Modes        "800x600" "640x480"
        EndSubSection
EndSection
        
RTFM | STFW | EMFP --------------------- [ code matrix ] [edited by - elendil67 on December 8, 2002 8:54:00 PM]

Share this post


Link to post
Share on other sites
Advertisement
Post your /etc/X11/XF86Config please,or just the Screen Section, so we all can see your problem, maybe re-running xf86config will solve your problem,but sometime you have to manually edit your XF86Config file.

Share this post


Link to post
Share on other sites
Thanks for your suggestion, hpolloni. Do you know what section is stated as the screen section? Also, so I can get the config file on the forum, do you know how I can copy in vi and paste in lynx? Thanks for your consideration.

RTFM | STFW | EMFP
---------------------
[ code matrix ]

Share this post


Link to post
Share on other sites
Dunno how to copy/paste, but I think the screen section is the one that starts with [SCREENS]. But i''m not sure.

Share this post


Link to post
Share on other sites
I had this problem. My memory is a bit cloudy on the matter, but I think the solution was to run xf86cfg, rather than xf86config. Debian comes with two versions of xfree86, for some reason.

Share this post


Link to post
Share on other sites
quote:
Original post by elendil67
Thanks for your suggestion, hpolloni. Do you know what section is stated as the screen section?


It's the section(s) labeled "Screen".
quote:

Also, so I can get the config file on the forum, do you know how I can copy in vi and paste in lynx? Thanks for your consideration.

If you have gpm installed (and running) you can select text with the mouse and then click the middle mouse button where you want to paste it (tip: use multiple virtual consoles).

Look here for info about the format of XF86Config. That's for version 4.2.1, if you have another version, it may be a little different (it should be consistent across 4.x versions, but if you have a 3.x version, then it's definitely different). In that case look at the docs for your version at www.xfree86.org.

[edited by - Dactylos on December 8, 2002 1:03:37 AM]

Share this post


Link to post
Share on other sites
The screen section looks fine, try posting the "Device" and "Monitor" sections as well.

Share this post


Link to post
Share on other sites
Yeah, post device and monitor sections too.

(EE) means error.

Look above in the log for any other errors that might be relavent.
You''re probably just using a bad video driver or have bad monitor parameters.

You will need to edit the config file or run the config program again though to correct it. Try playing around with the video settings to get something basic working (like vga). Then start to add your own stuff to see where things go awry.

___________________________
Freeware development:
ruinedsoft.com

Share this post


Link to post
Share on other sites
Try removing the Use FBDev option, that caused problems for me (I have an NVidia tho, so maybe not).

Everything else looks fine, if the above doesn''t work, try chainging the default color-depth to 16, then the "ati" part to "vesa".

Share this post


Link to post
Share on other sites
I had the same problem with my NVidia card after I changed my kernel form 2.4.19 to 2.4.20.

All I had to do was to re-install the driver modules for my current kernel. So you could make sure that all modules needed by the video driver are actually installed in the right place.

Share this post


Link to post
Share on other sites
Thanks everyone for your help. I am now writing this in Gnome! I removed the UseFBDev thing. Thanks so much for all of your help!


"I''ve discovered a trend. Every time I read a topic heading and say "Jeez... what kind of meathead came up with that?", I always seem to find Warsong''s elendil''s name one column over."
- InnocuousFox

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Flamebait of the week club! This weeks flamebait:
YOUR BIBLE IS FULL OF LIES!

[  c o d e  m a t r i x  ]

Share this post


Link to post
Share on other sites

  • Advertisement