Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

HappyDude

Polygons showing through

This topic is 5838 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Just learning OpenGL, and I have a problem where polygons at the back will show up in front of polygons at the front, because they are rendered last. Is there anyway to enable some kind of depth testing to make sure that the polygons being drawn aren''t behind another one?

Share this post


Link to post
Share on other sites
Advertisement
Definately, try:

glDepthFunc(GL_LEQUAL);
glEnable(GL_DEPTH_TEST);


------------
MSN: nmaster42@hotmail.com, AIM: LockePick42, ICQ: 74128155
"It''s all part of the conspiracy of conspirators conspiring to conspire their own conspiracies..."

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!