Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Thrump

OpenGL opengl in vc7 (winXP)

This topic is 5711 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m having a rough time getting anything using opengl to build. I''m getting linker errors like the following: error LNK2019: unresolved external symbol _glTexSubImage2D referenced in function "blah" In the project properties dialog under Linker->Input->Additional Dependencies I''ve added opengl32.lib I have the directory it''s in as an additional library directory. I first tried my own project, then a lesson from Nehe''s site. After conversion from VC6 to 7 I get this problem. I''ve done this 1001 times from VC6 without ever having this much trouble. PS: I had some trouble tracking down opengl32.lib and glu32.lib from a reliable up-to-date source. Should they be at opengl.org? I can never find them there. Where can I get these files?

Share this post


Link to post
Share on other sites
Advertisement
The OpenGL libraries are implementation only which means companies like Microsoft have there own implementations of it. Have you tried copying your gl header and library files from VC6 into VC7. If that doesn''t solve the problem you''re probably including the libraries wrong, although I SERIOUSLY dought that.

Adrian


OMG. It''s him again. Call the SHRINK!!!
rambo_bones@hotmail.com
WebSite: http://www.illicitdev.net/~rambobones
GlRott Page: http://www.glrott.tk

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
The opengl32.lib and glu32.lib files should come with Visual Studio. Didn''t they come with VS 7?

Share this post


Link to post
Share on other sites
Hey, wha-da-ya-know? They do come with vc7. I got rid of the ones I was using and pointed the project towards these ones, but still the same problem.
I can''t try anything with vc6, because I don''t have it here. I''m staying with my parents for the xmas holiday and wanted to get some programming in, but so far I can''t even get anything to compile.

I think I''m including the libraries wrong. I''ve yet to find a spot to include them that makes sense. Ah, well. I''ll have another browse through the documentation the next time I''m super-bored.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!