Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Help

Making VC++6 aware of DX7

This topic is 6924 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have unzipped the SDK and run the setup program. However, I cannot compile even a simple Direct Draw test because it gives me this compilation error: --------------------Configuration: Mechanics - Win32 Debug-------------------- Build : warning : failed to (or don''t know how to) build ''C:\SDK\Mechanics\Debug\Mechanics.pch'' Compiling... Mechanics.cpp c:\sdk\mechanics\mechanics.cpp(264) : fatal error C1010: unexpected end of file while looking for precompiled header directive Error executing cl.exe. Mechanics.obj - 1 error(s), 1 warning(s) If anyone can tell me what steps I should take to link VC++6 with the DX7SDK files then please, let me know!

Share this post


Link to post
Share on other sites
Advertisement
you need to add the dx7 directories to VC6''s search path. Go to Tools->Options->Directories tab. Then for include files and library files add the path where you put dx7. make sure the dx7 directories are first in the lists.

then you need to link the correct dx7 libs with your project settings. Go to Project->Settings->Link tab and add the names of the libs you want to use (ie DDraw.lib, etc) (make sure always to include dxguid.lib) to the "Object/Library modules" text box.

I hope that helps. If it doesn''t, I''m afraid I''m not sure what''s wrong.

bcj

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
It does not look like a Linker error. Try Rebuild All and if your project is using stdafx.h file, make sure that you include it in Mechanics.cpp

Share this post


Link to post
Share on other sites
Well, I''m now just getting the second part of the error - the unexpected end of file error. Unfortunately I have no idea what I am doing but I have included all the necessary files and basically I am annoyed that something so ''simple'' is not better documented. Arrrgh! Help!

Share this post


Link to post
Share on other sites
You are getting that error because the compiler expects to find #include "stdafx.h" at the beginning of each cpp file.
Either you add that line to the files, or you remove the compiler setting from Project->Settings under the Compiler tab. I think the switch you want to remove is called /Y"stdafx.h" but I'm not sure.

The problem you're having has nothing to do with DirectX. It's because you didn't create an empty Win32 Application.

- WitchLord

Edited by - WitchLord on 5/4/00 4:31:55 PM

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!