Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

zd97le

Strange DDraw Problem

This topic is 6929 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi there my name is Dim. I am a newbie in directdraw and just trying to write a small wrapper that will support 8,16 and 32 bit depth. I have managed to find the necessary routines to produce the right color in the right coordinates. My problem is this, i cant initialize 1024x768 mode. I have viper 770 non ultra and i cant find the solution for more than a week now. I am doing everything right because all the other modes are initialized correctly except this one. I make the necessary enumerations, check if the mode is supported but still nothing. In the end i tried something else. I have the book Inside DirectX published by microsoft. There is some code in there and the first chapter with code has the setting mode part. I tried the same thing over there but still believe it or not 1024x768 can''t start. My question is this to you. How come some games can work in this mode and the official code from microsoft together with my code cant do it? Please help me with this because i am getting mad.

Share this post


Link to post
Share on other sites
Advertisement
Check the return code when you do SetDisplayMode(...).

The most common error is DDERR_INVALIDMODE, which means your card can''t do that mode.

If you want a list of all the modes you card can do, run the program "ddcaps.exe". I think it''s in the SDK/dxutil area.

-Buster

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!