Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

slyterence

Problems in the debug window...

This topic is 5636 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

These messages have always come up in the debug window of my VS .NET, and they''re no problem ///////////////////////////////////////////////////////// ''Poddle.exe'': Loaded ''D:\Programming\Poddle\Debug\Poddle.exe'', Symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\ntdll.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\kernel32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\winmm.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\user32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\gdi32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\advapi32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\rpcrt4.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\opengl32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\msvcrt.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\glu32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\ddraw.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\dciman32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\nvoglnt.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\mcd32.dll'', No symbols loaded. ''Poddle.exe'': Unloaded ''C:\WINDOWS\system32\mcd32.dll'' //////////////////////////////////////////////////// Now however, i''m getting the following coming up once i''m in my program. They don''t come up immediately though, only when I press a key... and my program seems to be ignoring the keypress in favour of VS bringing these messages up, so for example, the first time i press escape to quit, it doesn''t quit, but the window brings these up, then if i press escape again, it quits... ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\cd_clint.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\version.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\wsock32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\ws2_32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\ws2help.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\inetmib1.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\iphlpapi.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\snmpapi.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\mprapi.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\activeds.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\adsldpc.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\netapi32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\wldap32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\atl.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\ole32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\oleaut32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\rtutils.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\samlib.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\setupapi.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\rasapi32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\rasman.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\tapi32.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\system32\shlwapi.dll'', No symbols loaded. ''Poddle.exe'': Loaded ''C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.10.0_x-ww_f7fb5805\comctl32.dll'', No symbols loaded. Can anyone explain what''s doing this, and how I can stop it... Also, it doesn''t happen all the time, but I haven''t been able to figure out what exactly causes it, whether it''s something in the code, or possible another program I have running... Btw I''m running windows XP with VS .NET and service pack 1 installed, as well as latest detonator and motherboard drivers, and directx 9... Thanks $£¥ We scratch our eternal itch A twentieth century bitch We are grateful for Our Iron Lung

Share this post


Link to post
Share on other sites
Advertisement
It''s normal. Windows is loading the DLLs.
Example:
If u initialize a plugin with LoadLibrary(...), and the DLL is not loaded in memory yet, the system loads it.
Then you get a message like this:
''Poddle.exe'': Loaded ''DLL_Path'', No symbols loaded.

So your program is loading kernel32.dll (Windows kernel), glu32.dll and so on.
Then, windows loads wsock32.dll - Winsock has probably been initialized.

PM

Share this post


Link to post
Share on other sites
But why are the second lot of DLL''s only loaded once I press any key from inside my program??? It never used to do that before, and I''m pretty sure I''m not using anything from Winsock...

We scratch our eternal itch
A twentieth century bitch
We are grateful for
Our Iron Lung

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!