Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

neonfaktory

VC++ Debug Mode = Good, Release Mode = 60 errors!

This topic is 5647 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Yeah... I''m a bit confused. I''m using VC++ 6.0 and have been programming my project/running/testing it in Debug Mode this whole time. I just tried putting it into "Release" Mode, and I got a shat load of "Unresolved External" errors, about 60 of them. I''m pretty sure it''s a VC++ deal, but not positive. Any help as to why all these errors pop up in Release Mode?

Share this post


Link to post
Share on other sites
Advertisement
Release Mode and Debug Mode have different linker options.

If you add a lib to Debug, it doesn''t get added to release automatically.

So check to make sure you did include the libs in the release mode configuration

Share this post


Link to post
Share on other sites
Hey, thanks for the reply, I''ll try that out when I get home from work. That actually hit me a little bit after I posted when I thought about the fact that it was all OpenGL components that had Unresolved Externals, but again, I''m at work so I couldn''t try it out. Your post was still helpfull though, because I might not have been able to narrow it down to being the Linker Options in particular, as opposed to all that other crazy stuff in the options . Thanks alot

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!