Archived

This topic is now archived and is closed to further replies.

Xeee

A very weird problem with framerate

Recommended Posts

Xeee    144
I was working on an OpenGL 2d Game, and after finishing i tried to test it on different pc''s, the results came very strange, doesn''t make sense, so if someone can explain, i''d b very glad. Testing Results : 1- PII CELERON 500 Mhz, 192 mb sdram, ati rage 128 32 mb ---> 120 fps. 2- P4 1.8 Ghz, 512 mb ?? ram, geforce4 mx440 64mb ---> 60 fps. 3- P4 2 Ghz, 256 mb ?? ram, geforce2 mx400 64mb ---> 41 fps. 4- PIII CELERON 850 Mhz, 256 mb sdram, ati radeon 8500 32mn ---> 650 fps. 5- Amd Athlon 4 1600+ 1.4 Ghz, 256 mb sdram, s3 Prosavage/TwisterK 32 mb ---> 60 fps. thanks for help(?? means i don''t know whether sd/ddr/rd ram) xee..

Share this post


Link to post
Share on other sites
TWilliams    122
Lots of things can effect frame rate... Driver versions, software running in the background, lots of things. But what I find interesting is that the two fast cards were ATI and the two slow ones were Nvidia. I know that ATI has a better 2D engine, but I don''t think your using that since you did OpenGL. Chances are that the Nvidia cards are either running XP/2000 Default drivers (No / Horrible OpenGL!) or old Nvidia drivers. The S3 is probally never going to get good frame rate... sorry, Prosavage onboard cards aren''t exactly the greatest. Luckily a lot of the boards for AMD with the Prosavage also had a AGP slot!

Share this post


Link to post
Share on other sites
Metal Typhoon    122
quote:
Original post by Xeee
I was working on an OpenGL 2d Game, and after finishing i tried to test it on different pc''s, the results came very strange, doesn''t make sense, so if someone can explain, i''d b very glad.

Testing Results :

1- PII CELERON 500 Mhz, 192 mb sdram, ati rage 128 32 mb
---> 120 fps.
2- P4 1.8 Ghz, 512 mb ?? ram, geforce4 mx440 64mb ---> 60 fps.
3- P4 2 Ghz, 256 mb ?? ram, geforce2 mx400 64mb ---> 41 fps.
4- PIII CELERON 850 Mhz, 256 mb sdram, ati radeon 8500 32mn
---> 650 fps.
5- Amd Athlon 4 1600+ 1.4 Ghz, 256 mb sdram, s3 Prosavage/TwisterK 32 mb ---> 60 fps.

thanks for help(?? means i don''t know whether sd/ddr/rd ram)

xee..


check the vsync .. turn it off

Share this post


Link to post
Share on other sites
Ready4Dis    180
Check opengl driver strings (company, driver name, and version). Some are probably running with software drivers, while others aren''t. Also, check the drivers for vsync on by default.. change it to off by default to get higher frame rates.

Share this post


Link to post
Share on other sites
nail85    122
quote:
Original post by Xeee
check the vsync .. turn it off
really i forgot that important point, thanks.

can i turn off from inside my game ?

xee..


Of cource you can . You need to use WGL_swap_control extension. Here is the sample:

// Swap control
PFNWGLSWAPINTERVALEXTPROC wglSwapIntervalEXT = NULL;
PFNWGLGETSWAPINTERVALEXTPROC wglGetSwapIntervalEXT = NULL;
bool Init_WGL_EXT_swap_control()
{
if (!IsExtSupported("GL_WGL_EXT_swap_control"))
return false;

wglSwapIntervalEXT = (PFNWGLSWAPINTERVALEXTPROC)
wglGetProcAddress("wglSwapIntervalEXT");
wglGetSwapIntervalEXT = (PFNWGLGETSWAPINTERVALEXTPROC)
wglGetProcAddress("wglGetSwapIntervalEXT");

return true;
}

Call Init_WGL_EXT_swap_control in your initialization function. And then call:

wglSwapIntervalEXT( 0 );

This will disable v-sync.

Share this post


Link to post
Share on other sites
bmarci    786
hi,

I faced the same problem with DirectX8

I got a P4 1.6 256sdram, GeForce3ti200

1. Win98 140 fps
2. WinXP 63 fps

in my workplace:
3. Win2K P3 900Mhz + GeForce2 Mx400 45fps

with no vsync.

The strangest thing is that, the fps is max 63, even if I draw an empty screen. My monitor''s refresh rate is 100Hz.

My game runs twice faster on Win98 than XP
with the same hardware and drivers

Share this post


Link to post
Share on other sites