Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

zayonara

Newbie Problems!

This topic is 5731 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have just started to learn openGL and I started out with NeHe''s first tutorial. After I have gone through the whole code and wrote it in my VC++ compiler to test if the shit works and as expected, it didn''t work. Now I wonder what I done wrong, I have added the libraries, Opengl32.lib Glu32.lib Glaux.lib in Link and I get the following errors: E:\Projekt\openGL\test\test\code.cpp(141) : error C2143: syntax error : missing '')'' before ''{'' E:\Projekt\openGL\test\test\code.cpp(141) : error C2143: syntax error : missing '';'' before ''{'' E:\Projekt\openGL\test\test\code.cpp(144) : error C2181: illegal else without matching if And many more... The code is totally the same as in the tutorial. It seems like it can''t find the libraries... Please help a lost soul! [futurama addicted]

Share this post


Link to post
Share on other sites
Advertisement
Nop, this isn´t a library problem, maybe you forgot a character (";" or ")"), the errors given by the compiler say that.

Try deactivating parts of your code

If God with me, Who against me?

Share this post


Link to post
Share on other sites
Those are "syntax" errors, not library problems. Double check your code, the way you wrote it in. The first error on line 141, you missed a ")" before the "{" just like the error states. I take it you did not copy and paste the code in, you wrote it out. So you missed a few things. It happens to all of us.

I also looked at NeHe's OpenGL tutorials and they are excellent! They work too, all of them. It is a very good source to learn from.

Larry.

/* Nobody can MAKE you do anything, so don't blame anyone but yourself! */

[edited by - LarryP on February 7, 2003 6:31:26 PM]

Share this post


Link to post
Share on other sites
Ok, I thought it was a library problem because it seems like it can''t recognize the functions. There are errors in wierd places were there shouldn''t be errors. Well, well... I''ll look through the code a second time... Thanks for the tip.

Share this post


Link to post
Share on other sites
When you were wrting a funtion or a class u probably forgot to put a } at the end of your class, so the compiler thinks that your whole program is a class

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!