Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

masonium

Can't create a D3D8 device anymore

This topic is 5673 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

All of a sudden, my call to CreateDevice fails when using D3DDEVTYPE_HAL. Its worked countless times before and I didn''t change how or where I called the function, but suddenly it no longer works. The device is created, however, in D3DDEVTYPE_HAL. I''m using the same computer as I used when it worked before. What could be the problem? ''There''s something out there....something stupid...'' ''I think I''m going to be ill. Is that a problem for you?'' ''[You] overestimate my conscience by assuming that I have one.'' - Daria DirectInput8 with the Keyboard , DirectInput8 with the Mouse , Using DirectX Audio 8

Share this post


Link to post
Share on other sites
Advertisement
1) USE THE DEBUG D3D RUNTIME TO SEE ***WHY*** THE CALL FAILS.

2) Run DXDIAG and make sure you do the D3D tests in it - see if those work.

3) Try some of the SDK samples.



- If you''ve installed ANY software recently, even commercial stuff, there''s a possibility that its screwed up your DirectX configuration (I''ve witnessed very badly written installers that try to force on old versions of things like DirectX).

- If the application is windowed, and you (or some software such as OpenGL demos) has changed the bit depth of the desktop, that could account for it - some graphics chips don''t support 3D in some desktop modes - 24bit being the one which immediately springs to mind. If you have a Matrox or older 3Dfx card this would be my guess.

- Likewise if you/something has installed an updated driver for your video card which has changed settings - for example on most nVidia chips, the bitdepth of the depth (Z) buffer format **MUST** be equal to the bitdepth of your framebuffer format (the desktop depth in windowed mode) - because so many applications get this wrong and don''t call things CheckDepthStencilFormatMatch(), their drivers have a setting which when enabled overrides what the code specified in its PRESENT_PARAMETERS to ensure the formats match. A driver update may set the setting to off...


--
Simon O''Connor
Creative Asylum Ltd
www.creative-asylum.com

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!