Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Kavos

Odd mouse stuff...

This topic is 6917 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am in the process of make a top down space RTS kind of game, I got the starfield up but whenever I use the down arrow key to scroll I get little white dots and stuff apearing over my mouse, when I use the other arrow keys to scroll it works like its supposed to. I''m just wondering if any of you have heard of this and can give me a fix. ~Kavos btw, i''m using DirectX

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
do you have a snippet of code from your down arrow function?

Share this post


Link to post
Share on other sites
it could be because you dont turn the mouse pointer off before rendering the screen and then turn it on after you''re done (i had to do that when i was doing dos programming)

- pouya

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
That''s true pouya...make sure you render the pointer last. Also make sure you are clearing your back buffer after every frame so that you don''t have any residuals showing up when you flip.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
is your background pre-rendered or are you doing the star field on the fly?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!