Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Aragorn

OpenGL doublebuffer problem...

This topic is 6909 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi I''m new to OpenGL and writing my first ''test'' programm and I have the following problem: The program is supposed to show a rotating cube. With one buffer and glFlush() everything worked well. But then I added the PFD_DOUBLEBUFFER flag and SwapBuffers(hdc) funcion. And now the cube don''t rotate anymore, it''s shown in it''s start position but don''t move. Just when I resize the window it''s shown in the position it would have reached in the time. I''don''t know where the fault is, may be you know. Please help me P.S.: SwapBuffers() is called everytime it should and return TRUE

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
You can find "rotating cube" example in Nehe tutorials.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
sound like you call your "render scene" in windows callback handler under REDRAW/REPAINT/RESIZE....??? or you use GLUT to trigger repaint in a wrong way....???

you have something like:

init opengl

while( not exit )
{
clear buffer
render scene
swap buffer
}

??












Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!