Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Yonash

Blitting to overlay surface on nVidia chipsets troubles...

This topic is 5621 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I have been developing an application for video recording for uncommon Video Capture Card. I''ve been using DirectX 7 overlay surfaces to display captured images (UYVY format). There wasn''t any problems on ATI video gfx cards, but on nVidia chipsets when i''m blitting image from backbuffer surface to overlay surface and rescaling it, the image is not copied correctly! First of all the image is not rescaled! It has the same size as in source surface (backbuffer)! The second - I have got a lot of "trash" on the image, and i couldn''t change the position of the image in overlay surface. Please, let me know if any of You, Dear Readers, have met the same problem or even have found the solution for my troubles. Yonashek / Poland

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!