Archived

This topic is now archived and is closed to further replies.

RPM stuff

This topic is 5403 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, i''m a linux newbie (using RedHat 7.3) and i''m getting really bored with this rpm stuff, hope someone can help me. Here''s what''s happenning: Almost *everytime* i want to install an rpm, i get some message like "XYZ is required by this package". Then i go on the net, find XYZ, download XYZ, try to install XYZ. But when it''s about to install it, it says "WYZ is required to install XYZ". Damn, why is there *always* some required extra lib?? I don''t have my whole day to be looking for these packages, got things to do, you know. Please, does anybody have any sugestions of how can i make it easier? Thanks, Victor.

Share this post


Link to post
Share on other sites
Yes, the solution is to not use Redhat, because you get dependency hell all the time with RPMs. If you want to be able to do simple package installation, Debian is the way to go, because apt-get works wonderfully. Unfortunately, Debian can also be fairly difficult to get setup on your system. However, once it is setup, it''s easy to upgrade software.

Share this post


Link to post
Share on other sites
Erm, i''m just a newbie, i think Debian wouldn''t be best distro to start with...

Isn''t there some apt-get for redhat?

Thanks,
Victor.

Share this post


Link to post
Share on other sites
quote:
Original post by -vic-
Hi,

i'm a linux newbie (using RedHat 7.3) and i'm getting really bored with this rpm stuff, hope someone can help me. Here's what's happenning:

Almost *everytime* i want to install an rpm, i get some message like "XYZ is required by this package". Then i go on the net, find XYZ, download XYZ, try to install XYZ. But when it's about to install it, it says "WYZ is required to install XYZ".

Damn, why is there *always* some required extra lib?? I don't have my whole day to be looking for these packages, got things to do, you know. Please, does anybody have any sugestions of how can i make it easier?

Thanks,
Victor.


If you're looking for an easy solution, get URPMI, not sure if it exists for RedHat but visit the Mandrake web site and download it from there. It tries to automaticly solve dependencies, if it's able too. As I was saying, I'm not sure if it exists directly for RedHat but the Mandrake version should work fine on a RedHat box.


[Cyberdrek | the last true sorcerer | Spirit Mage - mutedfaith.com][ Administrator TheLinuxForum.tk]

[edited by - cyberdrek on March 2, 2003 3:13:02 PM]

Share this post


Link to post
Share on other sites
There''s also a distro called Gentoo which has a different package system called "Portage". However, it''s a tough distro to set up...but it''ll speed up your learning curve tremendously.

I''ve played with Gentoo, and I say it''s not for the faint of heart. Not to mention it takes HOURS to install. However, once you do get it installed, you will have hands-down, the fastest Linux distro out there...even faster than Slackware.

Check out the installation directions here

Share this post


Link to post
Share on other sites