Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Blaster

Cube map bug (mapping works fine, texture does not)

This topic is 5619 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to use cube mapping to texture a terrain object. I store the texture in a DDS file, and the loading works fine with D3DXCreateCubeTextureFromFile (at least it doesn't return any error). The mapping also works fine, I think. Everything looks like it's reflected (I still have to add the texture matrix to move the cube map into world space). The problem is with the actual content of the texture. It's all black with a white box pattern. I am sure the DDS file is ok, because I tried with a cube map DDS file from the SDK and it does the same thing. (Edit)I have more info. I tried saving back a face of the cube map into a BMP file. The content of the surface is correct. I must be doing something wrong somewhere else. Here is a screenshot of the terrain from high above, looking down. ---------------- Blaster Computer game programmer and part time human being Strategy First - http://www.strategyfirst.com BlasterSoft - http://www.blastersoft.com [edited by - Blaster on March 3, 2003 3:07:51 PM]

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!