Archived

This topic is now archived and is closed to further replies.

Sir_Spritely

VertexShader stopped working??

Recommended Posts

I''m working on a vertexshader and I ended up with some odd error message: - Generic Application Error. Enable debug output for detailed information. Switching to the software reference raserizer, a software device which implements the entire Direct3D feature set but runs very slowly. Once I click okay on this message I then get: - Generic Application Error. Enable debug output for detailed information. This sample will now self destruct in ten seconds. This is happening on my code, the SDK''s VertexShader and the .exe vertexshader on the SDK in the bin directory. All other D3D examples and code are working fine just these. I tried with a different .VSH file but still getting the same problem. The MS SDK VertexShader examples were working fine a while back and now they aint? Anyone got any idea at all on this one?

Share this post


Link to post
Share on other sites
Does your hardware support HW vertex shaders? If you are on GF1/2 you will need to be in MIXED vertex processing mode and set the software flag on the vertex shader.

Neil

WHATCHA GONNA DO WHEN THE LARGEST ARMS IN THE WORLD RUN WILD ON YOU?!?!

Share this post


Link to post
Share on other sites
Yeah it does support that as the VertexShader SDK example worked before and now it won''t. I don''t think I''ve modified anything either, thats why I''m so perplexed over this?

Share this post


Link to post
Share on other sites
Changed drivers? What happens with the debug d3d driver (selected from control panel)?

Neil

WHATCHA GONNA DO WHEN THE LARGEST ARMS IN THE WORLD RUN WILD ON YOU?!?!

Share this post


Link to post
Share on other sites
Sorry for being stupid but how exactly do I change the driver to the debugd3d driver? You mentioned the Control Panel but I can''t see what to do from that. WINXP btw.

Share this post


Link to post
Share on other sites
It''s sorted, I must have changed one of the registers in the Ripple.vsh file by accident at some stage. I change it back from 15 to 5 and it works fine now, sorry for the hassle. But I learnt more about debugging dx apps, so all was not a loss

Share this post


Link to post
Share on other sites