Archived

This topic is now archived and is closed to further replies.

NasMan

Library

Recommended Posts

Hello, I''m new to OpenGL. I''m using .NET C++ dev environment to hack/learn how to program with OpenGL. Everything is fine. I can compile and run all OpenGL examples. I have one question...my development configuration is set for debug. I can compile and run programs fine like this. When I actually try and debug (step into the code) I get a "There is no source code available for the current location" dialog box with a "Show Disassembly" button. Also, when I switch the project to be a "Release" configuration and do a build, I get a ton of "unresolved external" errors. I''m not sure why this is happening...anyone know? Thanks

Share this post


Link to post
Share on other sites
Release:
Yoour linker settings (libs etc) are only set for debug mode...
Set the project settings for All modes

Source Code:
I think your source has been moved after you created the exe file....



PM



I hope GeForce FX is a joke .


Excuse my poor english!

Share this post


Link to post
Share on other sites
Checking the libraries on the link tab is all well and good, but you can also

#pragma comment(lib, "opengl32.lib")

in your main file to tell the linker where to look for symbols.

For the source files. The debugger may be trying to find the opengl source files or it''s looking in the wrong place for "your" source files. In VS6.0 you could go into Tools->Options->Directories Tab choose "Source Files" in the "Show directories for:" dropdown box and add directories for either the MFC source or OpenGL header files.

Share this post


Link to post
Share on other sites