Archived

This topic is now archived and is closed to further replies.

Colin Jeanne

Wrestling The STLPort

Recommended Posts

Colin Jeanne    1114
The other day I found out that apparently Dinkumware does not support the copy_n() nor min() algorithms so I thought it would be a good time to change to the STLPort instead. I think I installed it ok - there weren''t any errors that I encountered. I installed it for MSVC++ and I am using the STLPort''s iostreams. I have not made any changes to any of the configuration headers. However, the problem I''m having is that it seems that the STL is linking libcmt.lib which is conflicting with libcd.lib. I looked around for a way to turn off multithreading in the STL but I cant seem to find it. I tried defining both _NOTHREADS and NOTHREADS before including any other headers but that had no effect that I saw. Is there something that I am missing? Is there a configuration that I need to change in one of the STL headers?
Qui fut tout, et qui ne fut rien Invader''s Realm

Share this post


Link to post
Share on other sites
Kylotan    10003
Try defining _STLP_NO_THREADS in your project settings (ie. not in a file).

If that doesn''t work, look here:
http://www.stlport.com/dcforum/DCForumID7/1368.html. Let us know how you get on.

[ MSVC Fixes | STL | SDL | Game AI | Sockets | C++ Faq Lite | Boost | Asking Questions | Organising code files | My stuff ]

Share this post


Link to post
Share on other sites
Matsen    132
I got the same error, LNK2005, and I have tried the last tip mentioned in the stlport forum: "Replace /MTd with /MLd in line 70 and 76", but it did no good. After that I got tired and gave up. If you find a solution, please describe how you did it!

Regards Mats

Share this post


Link to post
Share on other sites