Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

FunkyTune

About Release mode in VC++6

This topic is 5620 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Today I noticed that when I run the game I''m making from the VC++ IDE (Release), some animations in my game doesn''t work. However, when I run the program file from Windows directly, everything works like it should. I''m not blaming VC++, I''m sure I made a mistake somewhere, but it would be easier to track down the problem if I knew what differences there are between running the file in Release vs. running it directly. Anyone? /John

Share this post


Link to post
Share on other sites
Advertisement
The only big difference is the current working directory. You should probably make your game extract the location of the exe (using GetModuleFileName) and load files relative to that path instead of the current working directory.

Share this post


Link to post
Share on other sites
No, that can''t be what''s causing the problem, because all the images, levels, sounds, etc. is loaded correctly in both cases. It just seems to refuse to execute a little part of my code, when run from the IDE. Really strange... Aren''t there any other difference?
Thanks for your reply, anyways.

/John

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!