Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

CWizard

[RH Linux] Gamma settings

This topic is 5307 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just installed RedHat Linux 9.0 on my home computer. This one''s monitor is such as that even brightness and contrast at 100%, I can hardly see anything that''s below %50 white. In Windows I use Adobe Gamma to correct this, and manages to get it fairly "normal". Now, I don''t know how to go about doing this feat in RH Linux (using Gnome, btw). I tried googling some, but fail to find any straight forward anwers. In addition to the gamma thing, I have another question: How do I change the monitor''s refresh frequency? When using 1024x800 @ 85Hz, the actual view area is about 1-2 inch smaller than at 75 Hz. Even though I am pretty familiar with *nix, most of my knowledge and understanding is theoretical rather than practical. Due to my lack of quantity experience with *nix systems, I tend to find myself lost in some areas, so please be detailed in any answers you give. Thanks for listening.

Share this post


Link to post
Share on other sites
Advertisement
I don''t know if there''s a GUI tool for gamma in Red Hat. If you can''t find anything, open a terminal and type "xgamma -h" (that will give you instructions on what to pass to xgamma).

About Frequency: Red Hat 9.0 uses the new XFree 4.3 which has a really nice way of doing this. I don''t rememeber what it''s called, but there will be a program in the menu to change the screen resolution as well as frequency. It''ll allow you to pick from a list.

Share this post


Link to post
Share on other sites
Thanks.

I did find a setting, in (sorry if terms aren''t right, I let it use swedish language when I installed) "System configuration"->"Display"->"Advanced"->"Display". There I could select my monitor''s model and it''s parameters, "refresh rate" among others. But, as the current value was "50-110 Hz" I assumed that it was the supported range, not the frequency to use. I entered 75, restarted X, and it worked.

xgamma (-gamma 2.5) did the trick. However, it was lost when X was restarted. Do you have any suggestion where I can change it permanently?


Share this post


Link to post
Share on other sites
quote:
Original post by CWizard
xgamma (-gamma 2.5) did the trick. However, it was lost when X was restarted. Do you have any suggestion where I can change it permanently?

To do it by hand, add "Gamma value" to a line in the Monitor section of your XF86Config-4 file (found in /etc/X11). Like I said, I have no idea if Red Hat has a GUI configuration tool for this, so that (by hand) may be the only way.

Share this post


Link to post
Share on other sites
quote:
Original post by Null and Void
To do it by hand, add "Gamma value " to a line in the Monitor section of your XF86Config-4 file (found in /etc/X11).
Yeah, that worked. Thanks again.


Share this post


Link to post
Share on other sites
quote:
Original post by klausewitz
I tried it by using "xgamma", but it has no effect. Is it possible that it doesnt works with vesa?

It wouldn''t surprise me to hear it doesn''t work when running through the vesa driver.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!