Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

bilsa

ASCII problem?

This topic is 5632 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! I''m having some problems with my ascii. When I press the "+" button on my keyboard, the ascii code I get is something on 219 which of course is wrong! I''m not sure why I get this so strange... I was very surprised when it happened. I mean... it''s not like the ascii tables are wrong or anything. By pressing the "+" button on my keyboard I should get the ascii code 43 right? I have a swedish language version of the keyboard, could that matter? Does anyone have any Idee why I get this problem? (If so... then any idee how to solve it?)

Share this post


Link to post
Share on other sites
Advertisement
Nope... it is the ascii code i get...

Another example is that when I press the "insert" button I get the ascii code 45.

Strange huh?

Share this post


Link to post
Share on other sites
neoztar may be right. It sounds suspiciously like a scan code. Give ToAscii() a shot.

If that doesn't work (or if you've already tried it), you should probably post the code you're using to read the keyboard.

EDIT: I did a quick check, and 45 is indeed the virtual key code for insert (VK_INSERT)

[edited by - glassjaw on April 20, 2003 7:30:10 PM]

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!