Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

LucasMeijer

Threads & FileIO, Difference on NT based OS's, and 95/98/ME

This topic is 5630 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I''m making a game, for which I''m constantly streaming in a lot of data from the harddrive. To make the whole game not freeze up for each dataread, I''m creating a thread for each time a bunch of data needs to be read. I do this using CreateThread(), which spawns a simple function that reads data from disk into a buffer. This all works great, on w2k and winxp. However on 95/98/me, it seems like the data is read in incorrectly. The data contains visuals, and I do actually see some of them in the game, but all offsetted correctly, as if the read operation was writing in a slightly wrong place in memory, but a different wrong one each time.. This is the same code that runs fine on w2k, which makes me believe there might be some ''gotcha'' on using threads that you want to work on all windows platforms. If you have any hints, ideas what the problem might be here, I''d love to hear about it. Thanks, Lucas

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!