Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

StormArmageddon

Vertex Buffer, Triangle List problems

This topic is 5632 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have noticed that when you create a vertex buffer that contains the D3DFVF_XYZRHW flag, the verticies are in screen x,y while D3DFVF_XYZ used world position. Why is this? Also, why can''t i create a quad using D3DFVF_XYZRHW but can using D3DFVF_XYZ? i can make triangles but can''t put two together. Any sample code on how to make a quad using D3DFVF_XYZRHW would greatly be appreciaded.

Share this post


Link to post
Share on other sites
Advertisement
Scratch that last message, i got it to work, but i have a new problem. when the texture values are [0] 0,0 [1] 1,0 [2] 0,1 [3] 1,1 the image doesn''t fill the box, instead the two y positions needed to be .75, is this typical or is my code messed up?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!